We are actively processing all queries and eSign queues, service have now restored. We’ll update this page if anything changes.
Posted Nov 14, 2025 - 10:14 EET
Investigating
We’re currently handling a higher than usual workload due to Black Friday activity. As a result, some requests may respond more slowly than normal. All systems remain operational, and our team is monitoring performance closely. We’ll update this page if anything changes.
Posted Nov 14, 2025 - 10:04 EET
This incident affected: Identification Services (e-Identification, WebID, Legal Person eID) and Signing Services (eSign, OTP eSign, Server Sign).