Delay in the processing of One time signing

Incident Report for Evrotrust

Resolved

The issue was Resolved. One time sinigang service is working as expected
Posted Nov 25, 2025 - 16:50 EET

Investigating

We are currently investigating an issue with our SMS provider, affecting One time signing services
Posted Nov 25, 2025 - 16:05 EET
This incident affected: Signing Services (OTP eSign).