Signing service degradation

Incident Report for Evrotrust

Resolved

All services are working as expected. All pending operations were processed. If You encounter any issues, please raise a ticked with our Support team.
Posted Nov 13, 2025 - 20:23 EET

Investigating

Signing service degradation has started at 16:15 UTC+2
We are investigating the issue with highest priority.
Posted Nov 13, 2025 - 17:37 EET
This incident affected: Signing Services (eSign, OTP eSign, Server Sign).