Face scanning service degradation

Incident Report for Evrotrust

Resolved

This incident has been resolved.
Posted Sep 15, 2026 - 10:18 EEST

Update

We are continuing to investigate this issue.
Posted Sep 15, 2026 - 09:20 EEST

Investigating

At the moment we are expiriencing an issue with the Fase scanning step in the mobile application.
The situation is investigated with the highest priority
Posted Sep 15, 2026 - 09:20 EEST
This incident affected: Identification Services (WebID).