Delay with Signing service

Incident Report for Evrotrust

Resolved

The problem was Resolved. All services are working as expected.
Posted Feb 11, 2026 - 12:58 EET

Identified

The cause of the behavior was identified, we are working to resolve the problem
Posted Feb 11, 2026 - 12:53 EET

Investigating

We are experiencing delay with signing service. The problem is investigated with the highest priority
Posted Feb 11, 2026 - 12:49 EET
This incident affected: Signing Services (eSign, OTP eSign, Server Sign).