Signing Portal Degradation

Incident Report for Evrotrust

Resolved

This incident has been resolved.
Posted Jan 17, 2026 - 22:03 EET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 17, 2026 - 21:50 EET

Investigating

We are currently experiencing slowdown in Signing Portal access. Users may have difficulties login and using the Portal services.
Posted Jan 17, 2026 - 17:47 EET
This incident affected: Signing Services (OTP eSign).